[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[EP-tech] Re: Bazaar-Plugins vs. New EPrint Versions



On 09/03/15 08:48, Denis Pitzalis wrote:
> Hi all,
>
> Maybe even easier would be to add a min_version and a max_version
> variables in the plugin definition. Like in PHP CMS. So we can define:
> $self->{min_version} = ?>= 3.3.10?;
> $self->{max_version} = ?< 3.3.12?;
>
> so we are sure that we always install the good version of a plugin.
>
> We could even go further and add a dependencies like:
> $self->{dependency} = ?icon-builder>1.1.4?;
>
> etc
>
> What do you think?

The downside to this approach is that plugins should remain compatible 
with all releases of EPrints (and certainly within a Version: 3.1; 3.2; 
3.3;...)
The changes that kill plugins are changes to API calls... and those 
shouldn't change within a version (so all function/api calls in 3.3.1 
should still work in 3.3.14 - though there may be additional 
functionality available within those calls, or via new calls)

I'd be happy with

$self->{min_version} = ?>= 3.2?;
$self->{max_version} = ?< 3.4?;

Anything else, and all Bazaar plugins automatically go "out of scope" on 
every new release, until they are tested against an install of that new 
release.

-- 

Ian Stuart.
Developer: ORI, RJ-Broker, and OpenDepot.org
Bibliographics and Multimedia Service Delivery team,
EDINA,
The University of Edinburgh.

http://edina.ac.uk/

This email was sent via the University of Edinburgh.

The University of Edinburgh is a charitable body, registered in
Scotland, with registration number SC005336.