[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[EP-tech] Move repository



Hi Ian,

I am not sure if you have had any success yet, but you can try the following which I think should work on eprints versions >=3.3.11.

Ideally, you should test on a non-production system and/or ensure you have a backup in place to fully restore if this does not work.

Please also note that $EPRINTS_HOME refers to wherever your eprints installation resides eg. /usr/share/eprints3/

I hope this helps; please let us know how you get on.

-------------------------------------------------------------------------------------------------------------------------
1
-------------------------------------------------------------------------------------------------------------------------
INFO
More info can be found by running ./epadmin help from your eprints bin directory
$EPRINTS_HOME/bin/epadmin help

CMDS
$EPRINTS_HOME/bin/epadmin config_core *repository_id*

->where *repository_id* = your repository id
-> make the changes to the eprints hostname here. The old ones will be presented as the defaults

-------------------------------------------------------------------------------------------------------------------------
2
-------------------------------------------------------------------------------------------------------------------------

INFO
More info can be found by running  ./generate_apacheconf --man from your eprints bin directory
$EPRINTS_HOME/bin/generate_apacheconf -man
If you manually edited myrepo.conf you will lose those changes here.
Regenerate your apache cpnfig
$EPRINTS_HOME/bin/generate_apacheconf --replace

-------------------------------------------------------------------------------------------------------------------------
3
-------------------------------------------------------------------------------------------------------------------------

Restart apache

service apache2 restart                 #ubuntu
service httpd restart                       #centos <6.7
systemctl restart httpd                  # centos 7

-------------------------------------------------------------------------------------------------------------------------
4
-------------------------------------------------------------------------------------------------------------------------

Regenerate the relevant pages
$EPRINTS_HOME/bin/generate_static *repository_id*
$EPRINTS_HOME/bin/generate_abstracts *repository_id*
$EPRINTS_HOME/bin/generate_views *repository_id*
$EPRINTS_HOME/bin/epadmin reload  *repository_id*

-------------------------------------------------------------------------------------------------------------------------
3
-------------------------------------------------------------------------------------------------------------------------

Restart apache

service apache2 restart                 #ubuntu
service httpd restart                       #centos <6.7
systemctl restart httpd                  # centos 7

-------------------------------------------------------------------------------------------------------------------------
4
-------------------------------------------------------------------------------------------------------------------------
Test



Best regards,
Kahena

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.ecs.soton.ac.uk/pipermail/eprints-tech/attachments/20160421/e1f50600/attachment-0001.html