[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[EP-tech] Re: Export subjects in 3.3.13 creates an empty XML



I didn?t have the same errors but did need to update the database after installing 3.3.13 to fix a subject import error.

Lizz

--
Lizz Jennings BA MSc ACLIP MCLIP (Revalidated 2014)
Technical Data Officer
The Library 4.10, University of Bath, Bath, BA2 7AY UK
Ext. 3570 (External 01225 383570)
E.Jennings at bath.ac.uk<mailto:E.Jennings at bath.ac.uk>
Research Data Management: http://www.bath.ac.uk/research/data


From: eprints-tech-bounces at ecs.soton.ac.uk [mailto:eprints-tech-bounces at ecs.soton.ac.uk] On Behalf Of pgasinos pgs
Sent: 03 March 2015 12:59
To: eprints-tech at ecs.soton.ac.uk
Subject: [EP-tech] Export subjects in 3.3.13 creates an empty XML

I have imported subject tree and converted in XML as usual (I have done it many times before in 3.3.12)

/usr/share/eprints3/bin/import_subjects <archive id>

/usr/share/eprints3/bin/export <archive id> subject XML > /usr/share/eprints3/archives/<archive id>/cfg/subjects.xml

but the result is an empty xml. I tried to reindex

./bin/epadmin reindex <archive id> subject and the result is:

You are about to reindex "subject" in the <archive id> repository.
This can take some time.

Number of records in set: 1
Continue [y/n] ? es
'el' is not a supported Xapian stem language, using English instead
Use of uninitialized value in concatenation (.) or string at (eval 97) line 54, <DATA> line 960.

I have attached the created xml file. What could be the problem?

Kostas Pgasinos
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.ecs.soton.ac.uk/pipermail/eprints-tech/attachments/20150303/fefc6163/attachment.html