[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[EP-tech] Re: My First Bazaar Package



Hi Simon,
I haven?t worked through the tutorial, but some of these might help :
 - Look in the Admin -> Misc Tools tab if there is one (see also: http://wiki.eprints.org/w/Where_Plugins_Appear)
 - Is there anything in the Apache error log?
 - Did you remember the '1;' at the end of lib/plugins/EPrints/Plugin/Screen/Hello.pm

 - When you ?enable? the package, the .pl file should be copied from:
lib/epm/hello_world/cfg/cfg.d/hello_world.pl
to
archives/ARCHIVEID/cfg/cfg.d/hello_world.pl
Does this look like it is happening?

Let us know how you get on!
Cheers,
John


From: eprints-tech-bounces at ecs.soton.ac.uk [mailto:eprints-tech-bounces at ecs.soton.ac.uk] On Behalf Of Simon Jennings
Sent: 06 October 2014 15:43
To: eprints-tech at ecs.soton.ac.uk
Subject: [EP-tech] My First Bazaar Package

Hi Everyone,
?
I've been working through the "My first Bazaar package" tutorial on the wiki:
?
http://wiki.eprints.org/w/My_First_Bazaar_Package
?
and can't seem to get it to work. I've completed all the steps, up to and including step 5. The package is installed and enabled with both the pm and the pl files in the correct directories:
?
lib/plugins/EPrints/plugin/Screen/Hello.pm
?
lib/epm/hello_world/cfg/cfg.d/hello_world.pl
?
After disabling the plugin, selecting the files, and then re-enabling I'm still not able to see the new tab or button in the admin -> system tools.
?
Any pointers in where I might be going wrong would be greatly appreciated.
?
Thanks,
?
Simon.

---------------------------------------------
Simon Jennings.
Research Data Management Software Developer
Library & Archives Service
London School of Hygiene and Tropical Medicine
?
simon.jennings at lshtm.ac.uk
?