[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[EP-tech] Re: About IRStats2



Yes
My repository is:
http://anaktisis.teiwm.gr

Kostas Pgasinos

???? ?????????, 25 ??????? 2014, ? ??????? Sebastien Francois <
sf2 at ecs.soton.ac.uk> ??????:

>  Hey,
>
> Do you have a URL I can look at?
>
> It seems like there are some issues with your data (the "countries' does
> not exist" error indicates some issues with Geo::IP). Do you get any
> related errors/warnings when you run "bin/epadmin test"?
>
> If that were possible, I'd re-generate all the stats:
>
> bin/stats/process_stats <id> --uninstall
>
> then
>
> bin/stats/process_stats <id> --setup --verbose
>
> As you know, this may take some time (depending on the size of your
> 'access' dataset).
>
> Kind regards,
> Seb
>
> On 25/07/14 08:12, pgasinos pgs wrote:
>
>   Thank you for your reply Seb
>
>  I am using EPrints 3.3.12 in Ubuntu server 12.04LTS and the latest
> IRStats2 from Bazzar (1.0.1)
>
> My apache log is:
>
> Stats::Handler: requested processor 'countries' does not exist.
> [Fri Jul 25 09:54:42 2014] [error] Can't call method "conf" on an
> undefined value at
> /usr/share/eprints3/lib/plugins/EPrints/Plugin/Stats/Data.pm line 200.\n
>
>  Do you suspect why authors stats have no entries? Subjects, University
> structure, Item type and EPrint ID are OK.
>
>  Thank you in advance
>  Kostas Pgasinos
>
>
> 2014-07-24 15:04 GMT+03:00 Sebastien Francois <sf2 at ecs.soton.ac.uk
> <javascript:_e(%7B%7D,'cvml','sf2 at ecs.soton.ac.uk');>>:
>
>>  Hello,
>>
>> Which versions of EPrints and IRStats2 are you using, and what's the
>> error in the apache error logs?
>>
>> Seb.
>>
>>
>> On 24/07/14 12:52, pgasinos pgs wrote:
>>
>>    In the Origin of downloads when I am trying to "Export as" any of the
>> XML or CSV I get a " Internal Server Error. The server encountered an
>> internal error or misconfiguration and was unable to complete your request."
>>
>>  Everything else (except Authors that also shows "No matches" no matter
>> what) seems to work.
>>
>> What might be the problem?  I believe I have installed correctly GeoIP
>> and Date::Calc modules
>>
>>
>>  Kostas Pgasinos
>>
>>
>>
>>
>>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.ecs.soton.ac.uk/pipermail/eprints-tech/attachments/20140725/40099bbb/attachment.html