[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[EP-tech] Eprints-Elements and the "ę"



Hello again all,

I took a look at the Apache error log  and got a line appearing saying
"Wide character in print at...".

Then a wise person let me know my problem and it was in the use of
"uri_escape" and "uri_escape_utf8" in a script; just in case anybody has a
similar problem.

So it is provisionally fixed.

Thanks for your time, advice and patience.

James

On Tue, Nov 13, 2018 at 2:29 PM Yuri via Eprints-tech <
eprints-tech at ecs.soton.ac.uk> wrote:

> You should post the traceback error in the log.
>
> Il 13/11/18 15:16, James Kerwin via Eprints-tech ha scritto:
> > They're in the Author field. When this author has been included for
> > other articles in the past those letters have been omitted.
> >
> > On Tue, Nov 13, 2018 at 2:04 PM John Salter <J.Salter at leeds.ac.uk
> > <mailto:J.Salter at leeds.ac.uk>> wrote:
> >
> >     Are these characters in the filename, or in the author field for
> >     the record to which the document is being uploaded?
> >
> >     *From:*James Kerwin [mailto:jkerwin2101 at gmail.com
> >     <mailto:jkerwin2101 at gmail.com>]
> >     *Sent:* 13 November 2018 13:59
> >     *To:* John Salter <J.Salter at leeds.ac.uk <mailto:J.Salter at leeds.ac.uk
> >>
> >     *Cc:* eprints-tech at ecs.soton.ac.uk
> >     <mailto:eprints-tech at ecs.soton.ac.uk>
> >     *Subject:* Re: [EP-tech] Eprints-Elements and the "?"
> >
> >     Hi John,
> >
> >     It was mostly trial and error using the pointers you gave me the
> >     first time I had upload trouble (upload a plain text file with a
> >     simple filename etc). It let me upload it with me as the author
> >     which is when I looked towards the "special" characters.
> >
> >     I've just done another upload on Test straight to EPrints (going
> >     around Elements and RT1/Crosswalks) including the author with
> >     special characters. It turns out there's both an "?" and a "?" (I
> >     thought it was an L, but it has a wiggle through the middle). Both
> >     letters by themselves cause the error (e.g. remove the ? it still
> >     happens, remove the ? it still happens, remove both and it's fine).
> >
> >     The upload straight to EPrints didn't work. When I clicked next it
> >     gave me the error below (not sure how this mailing list handles
> >     images). When I exchanged the characters for their more typical
> >     counterparts it went on without issue.
> >
> >     image.png
> >
> >     I'm not an expert, but I suspect now that this may be more a
> >     server issue than specifically EPrints as I would expect EPrints
> >     to refuse to save it or give me an EPrints-style warning.
> >
> >     Thanks,
> >
> >     James
> >
> >     On Tue, Nov 13, 2018 at 12:55 PM John Salter <J.Salter at leeds.ac.uk
> >     <mailto:J.Salter at leeds.ac.uk>> wrote:
> >
> >         Hi James,
> >
> >         If you add a record directly to EPrints, and use the character
> >         ? in a name (or other field), does it save OK?
> >
> >         I've just tried on a 3.3.10 install, and it seems to handle
> >         this without any issues - which might point to the issue being
> >         elsewhere.
> >
> >         Is there anything in the error logs regarding this - or was it
> >         a trial-and-error approach to find the cause of the problems?
> >
> >         Cheers,
> >
> >         John
> >
> >         *From:*eprints-tech-bounces at ecs.soton.ac.uk
> >         <mailto:eprints-tech-bounces at ecs.soton.ac.uk>
> >         [mailto:eprints-tech-bounces at ecs.soton.ac.uk
> >         <mailto:eprints-tech-bounces at ecs.soton.ac.uk>] *On Behalf Of
> >         *James Kerwin via Eprints-tech
> >         *Sent:* 13 November 2018 12:16
> >         *To:* eprints-tech at ecs.soton.ac.uk
> >         <mailto:eprints-tech at ecs.soton.ac.uk>
> >         *Subject:* [EP-tech] Eprints-Elements and the "?"
> >
> >         Hi all,
> >
> >         We have Elements and EPrints. Recently an article couldn't be
> >         uploaded to EPrints from Elements. After a fair bit of messing
> >         around, I've worked out the letter "/?" /is preventing the
> >         file upload (I removed the author with this letter and the
> >         file went on without a problem).
> >
> >         Unfortunately, this means the problem is with EPrints. Does
> >         anybody know of a straight-forward way of getting this to work
> >         without necessarily changing the spelling of the author's name?
> >
> >         I found this which I think might be my answer, but we're using
> >         3.3.14 so maybe there is another solution?
> >
> >
> https://emea01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwiki.eprints.org%2Fw%2FFix_for_better_UTF8_support&amp;data=01%7C01%7Ceprints-tech%40ecs.soton.ac.uk%7C2125922abb4a4fb7bbac08d6497cb7fc%7C4a5378f929f44d3ebe89669d03ada9d8%7C1&amp;sdata=eU9pQ8W%2FDaTEv635PqfnXaepCSDxjUv3VMpxfnFAFpQ%3D&amp;reserved=0
> >         <
> https://emea01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwiki.eprints.org%2Fw%2FFix_for_better_UTF8_support&amp;data=01%7C01%7Ceprints-tech%40ecs.soton.ac.uk%7C2125922abb4a4fb7bbac08d6497cb7fc%7C4a5378f929f44d3ebe89669d03ada9d8%7C1&amp;sdata=eU9pQ8W%2FDaTEv635PqfnXaepCSDxjUv3VMpxfnFAFpQ%3D&amp;reserved=0
> >
> >
> >         All advice and guidance greatly appreciated as ever!
> >
> >         Thanks,
> >
> >         James
> >
> >
> > *** Options:
> http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech
> > *** Archive:
> https://emea01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.eprints.org%2Ftech.php%2F&amp;data=01%7C01%7Ceprints-tech%40ecs.soton.ac.uk%7C2125922abb4a4fb7bbac08d6497cb7fc%7C4a5378f929f44d3ebe89669d03ada9d8%7C1&amp;sdata=RCBgpnrJoHIyZJkdsnI7oHIiESxZrbg8ITg%2BVIxT%2FNM%3D&amp;reserved=0
> > *** EPrints community wiki:
> https://emea01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwiki.eprints.org%2F&amp;data=01%7C01%7Ceprints-tech%40ecs.soton.ac.uk%7C2125922abb4a4fb7bbac08d6497cb7fc%7C4a5378f929f44d3ebe89669d03ada9d8%7C1&amp;sdata=stO%2BuYqOEaOw7hRvOtHyLhwVipSiHXHWTuKz4YYymMI%3D&amp;reserved=0
> > *** EPrints developers Forum:
> https://emea01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fforum.eprints.org%2F&amp;data=01%7C01%7Ceprints-tech%40ecs.soton.ac.uk%7C2125922abb4a4fb7bbac08d6497cb7fc%7C4a5378f929f44d3ebe89669d03ada9d8%7C1&amp;sdata=GoXmaz5rUn8Gghi9Y2sN3uInyw4H2NveTl91IEBdiJM%3D&amp;reserved=0
>
> *** Options: http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech
> *** Archive: https://emea01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.eprints.org%2Ftech.php%2F&amp;data=01%7C01%7Ceprints-tech%40ecs.soton.ac.uk%7C2125922abb4a4fb7bbac08d6497cb7fc%7C4a5378f929f44d3ebe89669d03ada9d8%7C1&amp;sdata=RCBgpnrJoHIyZJkdsnI7oHIiESxZrbg8ITg%2BVIxT%2FNM%3D&amp;reserved=0
> *** EPrints community wiki: https://emea01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwiki.eprints.org%2F&amp;data=01%7C01%7Ceprints-tech%40ecs.soton.ac.uk%7C2125922abb4a4fb7bbac08d6497cb7fc%7C4a5378f929f44d3ebe89669d03ada9d8%7C1&amp;sdata=stO%2BuYqOEaOw7hRvOtHyLhwVipSiHXHWTuKz4YYymMI%3D&amp;reserved=0
> *** EPrints developers Forum: https://emea01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fforum.eprints.org%2F&amp;data=01%7C01%7Ceprints-tech%40ecs.soton.ac.uk%7C2125922abb4a4fb7bbac08d6497cb7fc%7C4a5378f929f44d3ebe89669d03ada9d8%7C1&amp;sdata=GoXmaz5rUn8Gghi9Y2sN3uInyw4H2NveTl91IEBdiJM%3D&amp;reserved=0
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.ecs.soton.ac.uk/pipermail/eprints-tech/attachments/20181113/7dcf04cc/attachment-0001.html