[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[EP-tech] bazaar still unknown after upgrade to 3.4



Hi Thomas,

It should not be necessary but to be certain one way of other whether
this is the issue, please could you add the following lines under "use
strict;" in
/usr/share/eprints3/ingredients/bazaar/plugins/EPrints/Plugin/Screen/
Admin/EPM/Available.pm:

use EPrints::DataObj::EPM;
use EPrints::EPM::Source;

The instructions are based on upgrading repositories that have a
site_lib for site specific Perl modules and we may not have spotted
that these are not included somewhere other than there. ?It might also
be worth updating /usr/share/eprints3/flavours/pub_lib/inc and removing
site_lib so it is just:

flavours/pub_lib;ingredients/bazaar;

It does not look like having something in the include path that does
not exists is causing a problem with the ingredient being loaded, as
EPrints can see Available.pm in the ingredient. ?However, it looks like
other files in the ingredient have been loaded, so there is an outside
chance it may have some impact.

Regards

David Newman


On Thu, 2018-08-30 at 09:38 +0200, th.lauke at arcor.de wrote:
> Hi all,
> 
> after finishing all actions on https://wiki.eprints.org/w/Upgrading_3
> .3.12%2B_to_3.4
> the klick on 'EPrints Bazaar' results in
> 
> Unknown dataset: epm??and
> Undefined subroutine &EPrints::EPM::Source::accolades called at
> /usr/share/eprints3/ingredients/bazaar/plugins/EPrints/Plugin/Screen/
> Admin/EPM/Available.pm line 287.
> 
> What's wrong?
> 
> Thanks in advance for any hint
> Thomas
> *** Options: http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-
> tech
> *** Archive: http://www.eprints.org/tech.php/
> *** EPrints community wiki: http://wiki.eprints.org/
> *** EPrints developers Forum: http://forum.eprints.org/