[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[EP-tech] Eprints migration



Hi Mitocariu Emilian,

The way that the admin search for EPrints, (i.e. the one linked of 
"Search Items" on the admin page), changes somewhat between earlier and 
the latest versions of EPrints 3.3.  The easiest way for me or others to 
advise would be if you could post a copy of 
/usr/share/eprints3/lib/cfg.d/eprint_search_staff.pl 
<http://eprint_search_staff.pl>.

Regards

David Newman



On 03/04/2017 08:04, Mitocariu Emilian wrote:
> Hello,
>
> I'm trying to migrate the data from an old eprints server (ubuntu 
> 10.04, eprints 3.3.7) to a new one (ubuntu 16.04, eprints 3.3.15). 
> Maybe worth mentioning i had some problems when trying to install 
> eprints and i used the steps from here 
> http://www.eprints.org/tech.php/22140/attachment/message.html 
> <http://www.eprints.org/tech.php/22140/attachment/message.html> 
> to successfully install it.
>
> I moved the repository to the new server, but when i use the import 
> script on the XML I exported from the old server, i get this error:
>
> eprints at myserver:~/bin$ ./import library --verbose --migration archive 
> XML library.xml
> \C is deprecated in regex; marked by <-- HERE in m/(\C <-- HERE )/ at 
> /usr/share/eprints3/bin/../perl_lib/URI/Escape.pm line 205.
>
> ------------------------------------------------------------------
> ---------------- EPrints System Error ----------------------------
> ------------------------------------------------------------------
> Error in configuration:
> Can't use an undefined value as an ARRAY reference at 
> /usr/share/eprints3/lib/cfg.d/eprint_search_staff.pl 
> <http://eprint_search_staff.pl> line 16.
>
>
> ------------------------------------------------------------------
> EPrints System Error inducing stack dump
>  at /usr/share/eprints3/bin/../perl_lib/EPrints.pm line 147.
> EPrints::abort("EPrints") called at 
> /usr/share/eprints3/bin/../perl_lib/EPrints/Config.pm line 281
> EPrints::Config::load_repository_config_module("library") called at 
> /usr/share/eprints3/bin/../perl_lib/EPrints/Repository.pm line 510
> EPrints::Repository::load_config(EPrints::Repository=HASH(0x8d06c0)) 
> called at /usr/share/eprints3/bin/../perl_lib/EPrints/Repository.pm 
> line 153
> EPrints::Repository::new("EPrints::Repository", "library", "cgi", 0, 
> "noise", 2) called at /usr/share/eprints3/bin/../perl_lib/EPrints.pm 
> line 555
> EPrints::repository(EPrints=HASH(0x8d0498), "library", "noise", 2, 
> "cgi", 0) called at 
> /usr/share/eprints3/bin/../perl_lib/EPrints/BackCompatibility.pm line 447
> EPrints::Session::new("EPrints::Session", 1, "library", 2) called at 
> ./import line 208
>
> I also tried the method on your wiki 
> (https://wiki.eprints.org/w/Moving_a_repository) with the mysqldump 
> but when i do "./bin/epadmin upgrade library" i get the same error.
>
> If you have any idea what the problem might be i would be very glad.
> Thank you.
>
>
> *** Options: http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech
> *** Archive: http://www.eprints.org/tech.php/
> *** EPrints community wiki: http://wiki.eprints.org/
> *** EPrints developers Forum: http://forum.eprints.org/

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.ecs.soton.ac.uk/pipermail/eprints-tech/attachments/20170403/6514254c/attachment-0001.html