[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[EP-tech] Re: Plugins: enabled by default?



Hi Thomas,
I think the four tests below should show that things are OK.
As we're altering the config we need to restart apache between each test.

The tests are complicated by the fact that the archives don't load in a specific order (I'm sure they used to load alphabetically!). This might make some of the tests invalid.

I'll try and get a VM running 3.3.14 today and run some tests myself - if you have time to take a look at these, please do - if not, I'll hopefully be able to answer it myself later!

Cheers,
John

Test 1 (same config on B40 and b40literatur):
conf:
B40	z_plugin_test.pl:	(empty)
b40lit	z_plugin_test.pl:	(empty)
expected test results:
B40	PluginTestA:		Error
b40lit	PluginTestA:		Error
B40	PluginTestB:		Error
b40lit	PluginTestB:		Error

Test 2 (add TestA config to B40)
B40	z_plugin_test.pl:	$c->{plugins}->{"Screen::PluginTestA"}->{params}->{disable} = 0;
b40lit	z_plugin_test.pl:	(empty)
B40	PluginTestA:		Screen "This is: PluginTestA"
b40lit	PluginTestA:		Error
B40	PluginTestB:		Error
b40lit	PluginTestB:		Error

Test 3 (add TestA and TestB config to B40)
B40	z_plugin_test.pl:	$c->{plugins}->{"Screen::PluginTestA"}->{params}->{disable} = 0;
				$c->{plugins}->{"Screen::PluginTestB"}->{params}->{disable} = 0;
b40lit	z_plugin_test.pl:	(empty)
B40	PluginTestA:		Screen "This is: PluginTestA"
b40lit	PluginTestA:		Error
B40	PluginTestB:		Screen "This is: PluginTestB"
b40lit	PluginTestB:		Error

Test 4 (add TestA and TestB config to B40)
B40	z_plugin_test.pl:	$c->{plugins}->{"Screen::PluginTestA"}->{params}->{disable} = 0;
b40lit	z_plugin_test.pl:	$c->{plugins}->{"Screen::PluginTestA"}->{params}->{disable} = 0;
B40	PluginTestA:		Screen "This is: PluginTestA"
b40lit	PluginTestA:		Screen "This is: PluginTestA"
B40	PluginTestB:		Error
b40lit	PluginTestB:		Error


-----Original Message-----
From: Thomas Lauke [mailto:th.lauke at arcor.de] 
Sent: 03 November 2015 08:43
To: eprints-tech at ecs.soton.ac.uk
Cc: John Salter
Subject: Re: Plugins: enabled by default?

Hi John,

> For one of the archives, you should get a screen that doesn't show the error ...
no, both plugins fail on both repositories :(
For
b40literatur - - [03/Nov/2015:08:35:34 +0100] "GET /cgi/users/home?screen=PluginTestA HTTP/1.1" 200 1756 0
b40literatur - - [03/Nov/2015:08:35:40 +0100] "GET /cgi/users/home?screen=PluginTestB HTTP/1.1" 200 1753 0
b40literatur:8080 - - [03/Nov/2015:08:34:02 +0100] "GET /cgi/users/home?screen=PluginTestB HTTP/1.1" 200 2051 0
b40literatur:8080 - - [03/Nov/2015:08:34:16 +0100] "GET /cgi/users/home?screen=PluginTestA HTTP/1.1" 200 2048 0
I got no error ... although
more /usr/share/eprints3/archives/B40/cfg/cfg.d/z_plugin_test.pl (configures b40literatur) results in
$c->{plugins}->{"Screen::PluginTestA"}->{params}->{disable} = 1;

What's wrong?

Hth
Thomas