[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[EP-tech] Re: problem with multiple archives from



Are you running https?


--
Adam Field
Business Relationship Manager and Community Lead
EPrints Services



On 30 Oct 2015, at 15:15, John Salter <J.Salter at leeds.ac.uk> wrote:

> That all looks OK (I'm guessing 'loclhost' in the second one is a typo?)
> 
> Have you got any other config files that define 'base_url' or similar in:
> ~/archives/<dbis>/cfg/cfg.d/
> ~/archives/ <inf>/cfg/cfg.d/
> ~/lib/cfg.d/
> ~/lib/syscfg.d/
> ~/cfg/cfg.d/
> 
> The http paths configured in here: 
> https://github.com/eprints/eprints/blob/3.3/perl_lib/EPrints/Repository.pm#L504
> Which in turn calls _add_http_paths:
> https://github.com/eprints/eprints/blob/3.3/perl_lib/EPrints/Repository.pm#L715-L774
> and _add_live_http_paths:
> https://github.com/eprints/eprints/blob/3.3/perl_lib/EPrints/Repository.pm#L288-L300
> 
> - but these can be overridden in config files.
> 
> If none of that helps, if you look at the source-code for a page, are the links relative, or absolute?
> Do you have a <base...> element in your template?
> 
> Cheers,
> John
> 
> 
> 
> -----Original Message-----
> From: eprints-tech-bounces at ecs.soton.ac.uk [mailto:eprints-tech-bounces at ecs.soton.ac.uk] On Behalf Of Sebastian Schick
> Sent: 30 October 2015 14:41
> To: eprints-tech at ecs.soton.ac.uk
> Subject: [EP-tech] Re: problem with multiple archives from
> 
> Hi Thomas,
> 
> the content of <EprintsPath>/archives/<dbis>/cfg/cfg.d/10_core.pl is
> $c->{host} = 'dbis.localhost';
> $c->{port} = 80;
> $c->{aliases} = [];
> $c->{securehost} = '';
> $c->{secureport} = 443;
> $c->{http_root} = undef;
> 
> the content of <EprintsPath>/archives/<inf>/cfg/cfg.d/10_core.pl is
> 
> $c->{host} = 'inf.loclhost';
> $c->{port} = 80;
> $c->{aliases} = [];
> $c->{securehost} = '';
> $c->{secureport} = 443;
> $c->{http_root} = undef;
> 
> 
> 
> Is there something missing in the second conf file?
> 
> Sebastian
> 
> 
> On 30.10.2015 14:52, Thomas Lauke wrote:
>> Hi Sebastian,
>> 
>>> Why does eprints generate wrong links on the web pages?
>> imho the definition in <EprintsPath>/archives/<repoID>/cfg/cfg.d/10_core.pl is relevant during bin/generate_static ...
>> 
>> Hth
>> Thomas
> 
> 
> 
> *** Options: http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech
> *** Archive: http://www.eprints.org/tech.php/
> *** EPrints community wiki: http://wiki.eprints.org/
> *** EPrints developers Forum: http://forum.eprints.org/

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.ecs.soton.ac.uk/pipermail/eprints-tech/attachments/20151102/9e3e80d0/attachment.html