[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[EP-tech] Error upgrading from 3.3.12 to 3.3.13 using apt-get (Ubuntu)



Hi

I just wanted to apply security patches on my eprints system (ubuntu 12.04 LTS). I used the following commands as always
but the process suddenly stops with an error related to eprints.


# apt-get update
.
.
.
Hit http://security.ubuntu.com precise-security/multiverse amd64 Packages
Hit http://security.ubuntu.com precise-security/main i386 Packages
Hit http://security.ubuntu.com precise-security/restricted i386 Packages
Hit http://security.ubuntu.com precise-security/universe i386 Packages
Ign http://deb.eprints.org stable/ Release.gpg
Hit http://security.ubuntu.com precise-security/multiverse i386 Packages
Hit http://security.ubuntu.com precise-security/main TranslationIndex
Ign http://deb.eprints.org source/ Release.gpg
Ign http://deb.eprints.org stable/ Release
Hit http://security.ubuntu.com precise-security/multiverse TranslationIndex
Hit http://security.ubuntu.com precise-security/restricted TranslationIndex
Hit http://security.ubuntu.com precise-security/universe TranslationIndex
Ign http://deb.eprints.org source/ Release
Ign http://deb.eprints.org stable/ Packages/DiffIndex
Hit http://security.ubuntu.com precise-security/main Translation-en
Hit http://security.ubuntu.com precise-security/multiverse Translation-en
Hit http://security.ubuntu.com precise-security/restricted Translation-en
Ign http://deb.eprints.org source/ Sources/DiffIndex
Hit http://security.ubuntu.com precise-security/universe Translation-en
Hit http://deb.eprints.org stable/ Packages
Ign http://deb.eprints.org stable/ Translation-en_US
Ign http://deb.eprints.org stable/ Translation-en
Hit http://deb.eprints.org source/ Sources
Reading package lists... Done


root at eprints:~# apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages have been kept back:
  linux-headers-server linux-image-server linux-server
The following packages will be upgraded:
  bind9-host bsd-mailx coreutils cpio curl dnsutils eprints libbind9-80 libc-bin libc-dev-bin libc6 libc6-dev libcdt4 libcurl3 libcurl3-gnutls
  libdns81 libdrm-intel1 libdrm-nouveau1a libdrm-radeon1 libdrm2 libevent-2.0-5 libgraph4 libgvc5 libisc83 libisccc80 libisccfg82 libjasper1
  liblwres80 libnss3 libnss3-1d libpathplan4 libpixman-1-0 libpython2.7 libssl1.0.0 libudev0 linux-libc-dev mime-support multiarch-support
  mutt ntpdate openssl python-lazr.restfulclient python2.7 python2.7-minimal tcpdump udev unzip
47 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
Need to get 28.7 MB of archives.
After this operation, 424 kB of additional disk space will be used.
Do you want to continue [Y/n]? Y
WARNING: The following packages cannot be authenticated!
  eprints
Install these packages without verification [y/N]?Y
.
.
.
<updates are applied to the system>
.
.
.
Processing triggers for ureadahead ...
ureadahead will be reprofiled on next reboot
Errors were encountered while processing:
 /var/cache/apt/archives/eprints_3.3.13_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
root at eprints:~#

Any idea why upgrade of eprints bails out? This never happened before.

Regards,
Oliver



+---------------------------+------------------------------------+
| Oliver Rehmann??????????? | Hochschule f?r Technik Rapperswil? |
| Dipl. El. Ing. FH???????? | Institute for Networked Solutions? |
| orehmann at hsr.ch           | Oberseestrasse 10, 8640 Rapperswil |
| Phone? +41 55 222 18 41?? | http://www.hsr.ch????????????????? |
+---------------------------+------------------------------------+