[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[EP-tech] {Disarmed} International characters in advanced search fail for XML-Export




Hi together,

(using ePrints V3.3.12)

found a strange behaviour in combination Advanced Search / Saved Search /
XML-Export whithin context of international characters: If we use a saved
search on a author/creator with german Umlauts (international encoding),
the XML-Export-Plugin returns an empty XML-Dataset. Database entry
savedsearch|spec looks like smart utf8 to us (look at the bottom of this
message).

Does anybody know this behaviour ...or better know how to fix it? :)

Cheers
 Jens


In detail:

1.) Creating an Advanced Searching for an author/creator WITHOUT German
Umlauts (e.g. "Vieler")

- Database shows spec:

?plugin=Internal&searchid=advanced&dataset=archive&exp=0%7C1%7C-date%2Fcreators_name%2Ftitle%7Carchive%7C-%7Ccreators_name%3Acreators_name%3AALL%3AEQ%3AVieler%7C-%7Ceprint_status%3Aeprint_status%3AANY%3AEQ%3Aarchive%7Cmetadata_visibility%3Ametadata_visibility%3AANY%3AEQ%3Ashow

- Screen-View:

http://www.<eprint-server>.ch/id/saved_search/<savedsearch_id>

will be redirected to

http://www.<eprint-server>.ch/cgi/search/archive/advanced?_action_search=1&dataset=archive&exp=0|
1|-date%2Fcreators_name%2Ftitle|archive|-|
creators_name%3Acreators_name%3AALL%3AEQ%3AVieler|-|
eprint_status%3Aeprint_status%3AANY%3AEQ%3Aarchive&order=-date%2Fcreators_name%2Ftitle


and works!

- XML-Export for our CMS:

 https://www
.<eprint-server>.ch/cgi/users/home?screen=Workflow%3A%3AExportSavedSearchResults&dataset=saved_search&dataobj=<savedsearch_id>

will be redirected to

https://www.<eprint-server>.ch/cgi/saved_search/export_zora_XMLforCMS2.xml?savedsearchid=<savedsearch_id>&_action_export=1&_output=XMLforCMS2

and works!


2.) Creating an Advanced Searching for an author/creator WITH German
Umlauts (e.g. "Kr?ger,G")

- Database shows spec:

?plugin=Internal&searchid=advanced&dataset=archive&exp=0%7C1%7C-date%2Fcreators_name%2Ftitle%7Carchive%7C-%7Ccreators_name%2Feditors_name%3Acreators_name%2Feditors_name%3AALL%3AEQ%3AKr%C3%BCger%2C
+G%7C-%7Ceprint_status%3Aeprint_status%3AANY%3AEQ%3Aarchive%7Cmetadata_visibility%3Ametadata_visibility%3AANY%3AEQ%3Ashow

(so "Kr%C3%BCger" looks like good old utf8 stuff to me)

- Screen-View:

http://www.<eprint-server>.ch/id/saved_search/<savedsearch_id>

will be redirected to

http://www.<eprint-server>.ch/cgi/search/archive/advanced?_action_search=1&dataset=archive&exp=0|
1|-date%2Fcreators_name%2Ftitle|archive|-|
creators_name%2Feditors_name%3Acreators_name%2Feditors_name%3AALL%3AEQ%3AKr%C3%BCger%2C
+G|-|
eprint_status%3Aeprint_status%3AANY%3AEQ%3Aarchive&order=-date%2Fcreators_name%2Ftitle

and works!

- XML-Export for our CMS:

https://www
.<eprint-server>.ch/cgi/users/home?screen=Workflow%3A%3AExportSavedSearchResults&dataset=saved_search&dataobj=<savedsearch_id>

will be redirected to

https://www.<eprint-server>.ch/cgi/saved_search/export_zora_XMLforCMS2.xml?savedsearchid=<savedsearch_id>&_action_export=1&_output=XMLforCMS2

and fails... let's say: It's empty:

<?xml version="1.0" encoding="utf-8" ?>
<eprints xmlns="http://eprints.org/ep2/data/2.0";>
</eprints>

--
Jens Vieler
Informatikdienste
Universit?t Z?rich
Winterthurerstr. 190
CH-8057 Z?rich

mail:  jens.vieler at id.uzh.ch
phone: +41 44 63 56777
http://www.id.uzh.ch
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.ecs.soton.ac.uk/pipermail/eprints-tech/attachments/20150120/dbaa8f9f/attachment.html