[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[EP-tech] Re: system unable to send email (once more !)



Are you restarting apache every time you make configuration changes?


--
Adam Field
Business Relationship Manager and Community Lead
EPrints Services




On 13 Feb 2015, at 15:08, Laurent Cloarec wrote:

> Hello,
> 
> 
> In addition to our production server, I've just set up a test LAMP CentOS (6.x) 
> server with an installation of "EPrints" (3.3.13) software.
> 
> "Postfix" is configured (in /etc/postfix/main.cf, I've put the name of our SMTP 
> server in the "relayhost" parameter) on this CentOS server, and I'm able to send 
> emails from the command line (and receive them, of course !).
> 
> In the "perl_lib/EPrints/SystemSettings.pm",I have this :
> $EPrints::SystemSettings::conf =
> {
>         'user' => 'eprints',
>         'group' => 'eprints',
>         'smtp_server' => 'xxx'
> };
> where I've tried to write, instead of "xxx", the name of our university SMTP 
> server (works fine on production server) and 'localhost'
> With either value, when I try the "Send Test Email" admin tool, I receive the 
> old well known "The system is currently unable to send email" message...
> 
> So what's wrong ?
> 
> 
> Thanks, beforehand !
> 
> --
> Laurent Cloarec
> Service Commun de la Documentation - Service Num?rique Documentaire
> Biblioth?que Universitaire de l'Arsenal (bureau BU 017)
> Universit? Toulouse 1 Capitole
> 11 rue des Puits-Creus?s
> 31042  TOULOUSE  Cedex 9 (France)
> t?l. : (+33)(0)5.34.45.61.23
> 
> *** Options: http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech
> *** Archive: http://www.eprints.org/tech.php/
> *** EPrints community wiki: http://wiki.eprints.org/
> *** EPrints developers Forum: http://forum.eprints.org/