[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[EP-tech] Re: Error downloading Romeo autocomplete file from eprints.org



I'm sure you're right Alan.

SHERPA/RoMEO proper aquires its ISSNs from publishers' websites, and they often have em-dash and en-dash instead of a hyphen (usually thanks to Microsoft auto-formating). We're pretty good at catching these, although the odd ISSN error does occasionally slip through. I checked yesterday and found just 15 dodgy ISSNs, which I then duly corrected. Should you spot any more in the future, please send feedback to romeo at sherpa.ac.uk for our attention.

Best regards

Peter

Peter Millington
SHERPA Technical Development Officer
Centre for Research Communications
University of Nottingham, UK

________________________________________
From: eprints-tech-bounces at ecs.soton.ac.uk [eprints-tech-bounces at ecs.soton.ac.uk] On Behalf Of Alan.Stiles [alan.stiles at open.ac.uk]
Sent: 04 November 2014 09:14
To: eprints-tech at ecs.soton.ac.uk
Subject: [EP-tech] Re: Error downloading Romeo autocomplete file        from    eprints.org

Hi John,
At an educated guess, that looks a bit like a character set issue, possibly whether the ISSN is listed in the file with a hyphen or an em-dash (or an en-dash) and isn?t translating correctly into (or out of) UTF-8.
I currently have a similar issue with some internal data feeds causing me all manner of similar problems!
Alan

From: John Salter [mailto:J.Salter at leeds.ac.uk]
Sent: 03 November 2014 10:06
To: 'eprints-tech at ecs.soton.ac.uk'
Subject: [EP-tech] Re: Error downloading Romeo autocomplete file from eprints.org

Hi,
I?ve just tried ? downloaded OK for me. If you want a copy some other way, let me know.

One thing I did notice in the file:
Some ISSNs are fine:
<li id="for:value:component:_issn">0091-7613</li>

Some look ?interesting?:
<li id="for:value:component:_issn">0734&acirc;??7324</li>
or:

<li id="for:value:component:_issn">0734&acirc;<80><93>7324</li>

Looking at the Sherpa API record for this journal: http://www.sherpa.ac.uk/romeo/api29.php?issn=0734-7324, there doesn?t look to be anything wrong.

I?m not sure what processing happens to turn the romeo data into the autocomplete data - can someone at EPS explain what?s going on?
Cheers,
John


From: eprints-tech-bounces at ecs.soton.ac.uk<mailto:eprints-tech-bounces at ecs.soton.ac.uk> [mailto:eprints-tech-bounces at ecs.soton.ac.uk] On Behalf Of Mark Gregson
Sent: 03 November 2014 02:50
To: eprints-tech at ecs.soton.ac.uk<mailto:eprints-tech at ecs.soton.ac.uk>
Subject: [EP-tech] Error downloading Romeo autocomplete file from eprints.org


I?m getting HTTP 502 or 504 responses when requesting the Romeo autocomplete file from http://romeo.eprints.org/romeo_journals.autocomplete since 26/10. Our last successful download would have been 19/10.



I assume that others are having the same problem?  Does anyone know if it?s being addressed?



Cheers

Mark

Mark Gregson | Applications and Development Team Leader
Library eServices | Queensland University of Technology
Level 3 | R Block | Kelvin Grove Campus | GPO Box 2434 | Brisbane 4001
Phone: +61 7 3138 3782 | Web: http://eprints.qut.edu.au/<http://www.qut.edu.au/>
ABN: 83 791 724 622
CRICOS No: 00213J

-- The Open University is incorporated by Royal Charter (RC 000391), an exempt charity in England & Wales and a charity registered in Scotland (SC 038302). The Open University is authorised and regulated by the Financial Conduct Authority.