[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[EP-tech] eprints javascript error



Hello,

I have a javascript error that I would like to know if anyone has previously come across or has solved. Basically whenever I load any page I get these errors in the browser console:

TypeError: element.attachEvent is not a function  auto-3.3.15.js:6495:7
TypeError: element.dispatchEvent is not a function  auto-3.3.15.js:6603:5
TypeError: element.attachEvent is not a function  auto-3.3.15.js:6487:7
Use of getPreventDefault() is deprecated.  Use defaultPrevented instead. (i pasted this warning in too but its probably unrelated)

It has the effect of preventing the 'browse' menu drop down from opening and also, the options for the three admin action tabs (editorial tools, system tools, config. tools) are all situated on one tab, and changing between tabs does nothing.

These are the only issues I currently see, but I am afraid of what else might not function correctly because of this. Has anyone ran into this issue?

This issue happens in both firefox and chromium. I have just migrated from eprints version 3.3.10 on debian 6 to 3.3.15 on debian 9. I created a basic install and then cloned our institutes archive into the eprints archives folder, then regenerated all static files and views.


Thank you,
Jonathan Norris
IST Austria
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.ecs.soton.ac.uk/pipermail/eprints-tech/attachments/20171115/1d2025ec/attachment.html