[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[EP-tech] EPrints and Ubuntu 16.04



Hi all,

There was some user group feedback from the Repository Fringe regarding
the "Enterprise Compliance" of EPrints, specifically for Ubuntu 16.04.?

I am keen on ensuring that the next release of EPrints 3.3 has a Debian
package that can be directly installed from the APT repository at
deb.eprints.org, without need for some interesting hacks, which have
been previously discussed. ?At present I am aware of two issue with the
current EPrints 3.3.15 Debian package:

1. apache2-mpm-prefork no longer exists as a Debian package and causes
a failed dependency. ?This can be worked around by creating a fake
Debian package for this.

2. If Apache is installed to use the MPM event module, this is known to
have issues which can cause Apache to experience a segmentation fault.
?After some investigation, I believe this is down to LibXSLT.so, which
is installed by the Debian package libxml-libxslt-perl, which is a
dependency of EPrints. ?However, I have also found that I can manually
install and run EPrints quite happily without this package, including
successfully running the unit tests.

Based on this experience, I have created an modified version of the
EPrints 3.3.15 Debian package, which removed the apache2-mpm-prefork
dependency and replaces it with just an apache2 dependency and removes
the the libxml-libxslt-perl dependency altogether. ?I have successfully
installed and run the unit tests for this on my own Ubuntu 16.04 server
with only two minor issues:

1. A deprecation warning for the use of '\C' in a regular expression
the escape_char function of URI/Escape.pm
?
2. Unit tests for SWORD fail.
?
However, both these issues have been fixed on GitHub (https://github.co
m/eprints/eprints/) since EPrints 3.3.15 was released.

It would be useful if others could test my modified Debian package to
see if they can find any other issues with it. ?It is available at:

http://files.eprints.org/1712/

In particular:

1. Are there other situations where Apache will suffer a Segmentation
fault other than that caused by LibXSLT.so, which this Debian package
will no longer install.
?
2. Is the libxml-libxslt-perl package required for any core EPrints
functionality that has not been identified by running unit tests. (If
necessary, this library can be installed through CPAN rather than as a
Debian package and this way does not appear to cause a segmentation
fault).

I also intend to further test whether this modified EPrints 3.3.15
Debian package can successfully installed on Ubuntu 14.04, as it would
be preferable to have a single package for all currently supported
versions of Ubuntu. ?Based on the changes: only removing a dependency
and effectively relaxing another dependency, I believe that any use of
this package as an upgrade on an existing EPrints install should behave
the same as using the original EPrints 3.3.15 Debian package.

Any feedback on this would be greatly appreciated.

Regards

David Newman
EPrints Services

?
?