[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[EP-tech] Eprints migration



Hi

It looks like you do not have any advanced search fields set.  Can you 
find a file called eprint_search_advanced.pl either in the same 
directory or in your archive's cfg.d. directory (e.g. 
/usr/share/eprints3/archives/ARCHIVE_NAME/cfg/cfg.d/eprints_search_advanced.pl). 
If not you will want to create this file and add the code that follows 
this email.  If you do not have this file in either of the two 
directories I mention above, I am a little puzzled why, if this is an 
initial install using the Deb package.

Regards

David Newman

$c->{search}->{advanced} =
{
         search_fields => [
                 { meta_fields => [ "documents" ] },
                 { meta_fields => [ "title" ] },
                 { meta_fields => [ "creators_name" ] },
                 { meta_fields => [ "abstract" ] },
                 { meta_fields => [ "date" ] },
                 { meta_fields => [ "keywords" ] },
                 { meta_fields => [ "subjects" ] },
                 { meta_fields => [ "type" ] },
                 { meta_fields => [ "department" ] },
                 { meta_fields => [ "editors_name" ] },
                 { meta_fields => [ "ispublished" ] },
                 { meta_fields => [ "refereed" ] },
                 { meta_fields => [ "publication" ] },
                 { meta_fields => [ "documents.format" ] },
         ],
         preamble_phrase => "cgi/advsearch:preamble",
         title_phrase => "cgi/advsearch:adv_search",
         citation => "result",
         page_size => 20,
         order_methods => {
                 "byyear"         => "-date/creators_name/title",
                 "byyearoldest"   => "date/creators_name/title",
                 "byname"         => "creators_name/-date/title",
                 "bytitle"        => "title/creators_name/-date"
         },
         default_order => "byyear",
         show_zero_results => 1,
};


On 03/04/2017 08:52, Mitocariu Emilian wrote:
> Hi,
>
> This is the content of the 
> /usr/share/eprints3/lib/cfg.d/eprint_search_staff.pl: 
> <http://eprint_search_staff.pl>
>
> # Any changes made here will be lost!
> #
> # Copy this file to:
> # archives/[archiveid]/cfg/cfg.d/
> #
> # And then make any changes.
>
> $c->{datasets}->{eprint}->{search}->{staff} =
> {
>         search_fields => [
>                 { meta_fields => [qw( eprintid )] },
>                 { meta_fields => [qw( userid.username )] },
>                 { meta_fields => [qw( userid.name <http://userid.name> 
> )] },
>                 { meta_fields => [qw( eprint_status )], 
> default=>"archive buffer" },
>                 { meta_fields => [qw( dir )] },
>                 @{$c->{search}{advanced}{search_fields}},
>         ],
>         preamble_phrase => "Plugin/Screen/Staff/EPrintSearch:description",
>         title_phrase => "Plugin/Screen/Staff/EPrintSearch:title",
>         citation => "result",
>         page_size => 20,
>         order_methods => {
>                 "byyear"         => "-date/creators_name/title",
>                 "byyearoldest"   => "date/creators_name/title",
>                 "byname"         => "creators_name/-date/title",
>                 "bytitle"        => "title/creators_name/-date"
>         },
>         default_order => "byyear",
>         show_zero_results => 1,
>         staff => 1,
> };
>
> On Mon, Apr 3, 2017 at 10:44 AM, David R Newman <drn at ecs.soton.ac.uk 
> <mailto:drn at ecs.soton.ac.uk>> wrote:
>
>     Hi Mitocariu Emilian,
>
>     The way that the admin search for EPrints, (i.e. the one linked of
>     "Search Items" on the admin page), changes somewhat between
>     earlier and the latest versions of EPrints 3.3.  The easiest way
>     for me or others to advise would be if you could post a copy of
>     /usr/share/eprints3/lib/cfg.d/eprint_search_staff.pl
>     <http://eprint_search_staff.pl>.
>
>     Regards
>
>     David Newman
>
>
>
>     On 03/04/2017 08:04, Mitocariu Emilian wrote:
>>     Hello,
>>
>>     I'm trying to migrate the data from an old eprints server (ubuntu
>>     10.04, eprints 3.3.7) to a new one (ubuntu 16.04, eprints
>>     3.3.15). Maybe worth mentioning i had some problems when trying
>>     to install eprints and i used the steps from here
>>     http://www.eprints.org/tech.php/22140/attachment/message.html
>>     <http://www.eprints.org/tech.php/22140/attachment/message.html>
>>     to successfully install it.
>>
>>     I moved the repository to the new server, but when i use the
>>     import script on the XML I exported from the old server, i get
>>     this error:
>>
>>     eprints at myserver:~/bin$ ./import library --verbose --migration
>>     archive XML library.xml
>>     \C is deprecated in regex; marked by <-- HERE in m/(\C <-- HERE
>>     )/ at /usr/share/eprints3/bin/../perl_lib/URI/Escape.pm line 205.
>>
>>     ------------------------------------------------------------------
>>     ---------------- EPrints System Error ----------------------------
>>     ------------------------------------------------------------------
>>     Error in configuration:
>>     Can't use an undefined value as an ARRAY reference at
>>     /usr/share/eprints3/lib/cfg.d/eprint_search_staff.pl
>>     <http://eprint_search_staff.pl> line 16.
>>
>>
>>     ------------------------------------------------------------------
>>     EPrints System Error inducing stack dump
>>      at /usr/share/eprints3/bin/../perl_lib/EPrints.pm line 147.
>>     EPrints::abort("EPrints") called at
>>     /usr/share/eprints3/bin/../perl_lib/EPrints/Config.pm line 281
>>     EPrints::Config::load_repository_config_module("library") called
>>     at /usr/share/eprints3/bin/../perl_lib/EPrints/Repository.pm line 510
>>     EPrints::Repository::load_config(EPrints::Repository=HASH(0x8d06c0))
>>     called at
>>     /usr/share/eprints3/bin/../perl_lib/EPrints/Repository.pm line 153
>>     EPrints::Repository::new("EPrints::Repository", "library", "cgi",
>>     0, "noise", 2) called at
>>     /usr/share/eprints3/bin/../perl_lib/EPrints.pm line 555
>>     EPrints::repository(EPrints=HASH(0x8d0498), "library", "noise",
>>     2, "cgi", 0) called at
>>     /usr/share/eprints3/bin/../perl_lib/EPrints/BackCompatibility.pm
>>     <http://y.pm> line 447
>>     EPrints::Session::new("EPrints::Session", 1, "library", 2) called
>>     at ./import line 208
>>
>>     I also tried the method on your wiki
>>     (https://wiki.eprints.org/w/Moving_a_repository
>>     <https://wiki.eprints.org/w/Moving_a_repository>) with the
>>     mysqldump but when i do "./bin/epadmin upgrade library" i get the
>>     same error.
>>
>>     If you have any idea what the problem might be i would be very glad.
>>     Thank you.
>>
>>
>>     *** Options:http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech
>>     <http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech>
>>     *** Archive:http://www.eprints.org/tech.php/ <http://www.eprints.org/tech.php/>
>>     *** EPrints community wiki:http://wiki.eprints.org/
>>     *** EPrints developers Forum:http://forum.eprints.org/
>     *** Options:
>     http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech
>     <http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech> ***
>     Archive: http://www.eprints.org/tech.php/
>     <http://www.eprints.org/tech.php/> *** EPrints community wiki:
>     http://wiki.eprints.org/ *** EPrints developers Forum:
>     http://forum.eprints.org/ 
>
> *** Options: http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech
> *** Archive: http://www.eprints.org/tech.php/
> *** EPrints community wiki: http://wiki.eprints.org/
> *** EPrints developers Forum: http://forum.eprints.org/
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.ecs.soton.ac.uk/pipermail/eprints-tech/attachments/20170403/e9c34a16/attachment.html