[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[EP-tech] Importing EP3 borking with HTML entities



Hey all!

It's that moving from one repository to another time again!

However, the import keeps falling over as the EP3 export has HTML entities (most notably a ton of & and ' but the occasional > and <)

Importing from an XML export (3.3.10 ./export liverpool_integrated archive XML <some_repository_id_numbers> > <repository_export_file> ) to an XML import (3.3.14  ./import uolrepo --enable-web-imports --enable-import-fields --utf8 --verbose -user symplectic archive XML <importFILE>) it keeps crashing as the export has &amp; and &apos; in text fields - the importer crashes, complaining

Error! Unhandled exception in Import::XML: Can't use string (" ") as an ARRAY ref while "strict refs" in use at /opt/eprints3/bin/../perl_lib/EPrints/MetaField.pm line 2106. at /usr/local/lib/perl/5.18.2/XML/LibXML/SAX.pm line 101. at /opt/eprints3/bin/../perl_lib/EPrints/XML/LibXML.pm line 137.

If anyone has suggestions or solutions to get these imports working they would be much appreciated!

Thanks!

Adam

Adam Vials Moore | Repository Developer | Libraries, Museums and Galleries| PO Box 123 | Liverpool L69 3DA | mooread at liverpool.ac.uk|<mailto:mooread at liverpool.ac.uk%7C> T 0151 794 3844 |

Follow us: @LivUniLibrary<https://twitter.com/LivUniLibrary> Like us: LivUniLibrary<https://www.facebook.com/livunilibrary> Visit us: http://www.liverpool.ac.uk/library
Special Collections & Archives blog: http://manuscriptsandmore.liv.ac.uk<http://manuscriptsandmore.liv.ac.uk/>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.ecs.soton.ac.uk/pipermail/eprints-tech/attachments/20160330/e32b4dba/attachment.html