[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[EP-tech] ssmtp and eprints



There?s an error in there about ?wide character in print? ? it?s not just the smiley at the end of the subject line confusing it, is it?

Lizz

--
Lizz Jennings BA MSc ACLIP MCLIP (Revalidated 2015)
Technical Data Officer
The Library 4.10, University of Bath, Bath, BA2 7AY UK
Ext. 3570 (External 01225 383570)
E.Jennings at bath.ac.uk<mailto:E.Jennings at bath.ac.uk>
Research Data Management: http://www.bath.ac.uk/research/data


From: eprints-tech-bounces at ecs.soton.ac.uk [mailto:eprints-tech-bounces at ecs.soton.ac.uk] On Behalf Of Edward M. Corrado
Sent: 01 June 2016 22:38
To: eprints-tech at ecs.soton.ac.uk
Subject: Re: [EP-tech] ssmtp and eprints

Hi David,

Thanks for the suggestion about looking at the mail.log which I didn't think to do. I confirmed that nothing is being written there or to the mail.err log. So, I imagine that it is not getting that far for whatever reason.

It is possible that my idea of trying to use something simple like ssmtp has more complicated things. :-)

Thanks,
Edward

On Wed, Jun 1, 2016 at 4:28 PM, David R Newman <drn at ecs.soton.ac.uk<mailto:drn at ecs.soton.ac.uk>> wrote:

Hi Edward,

I think SSMTP also writes to /var/log/maillog so it may be worth checking that to see if there is anything useful.  I typically use Sendmail, which is a bit overkill but seems to be more helpful when I am trying to determine whether there is issues with SPF whitelists or similar.

I am not aware of any modifications to the EPrints configuration for sending mail beyond what you have described.

Regards

David Newman

On 01/06/2016 22:18, Edward M. Corrado wrote:
Hello,

I configured ssmtp on my Ubuntu box and it sends e-mails fine (via gmail) from the command line. However, whenever I try to send a test e-mail from Eprints (v. 3.3.15) on Ubuntu 14.04.4 LTS I get an error saying:


The system is currently unable to send email. Please try again later. If this problem persists, please contact the administrator with details.

The apache error.log file gets the following entry written to it:
Failed to create SMTP connection to smtp
Wide character in print at (eval 477) line 44.
Failed to send mail.
To: ecorrado at ecorrado.us<mailto:ecorrado at ecorrado.us> <>
Subject: Test email from http://codabox.org/ ?


Does anyone have any idea what to configure for ssmtp? I tried some thing I found in various old e-mails, but nothing seems to work.

The main things I have tried include: Defining my  smtp server in perl_lib/Eprint/SystemSeting.pm file.

> 'smtp_server' => 'smtphost.your.domain'

I tried localhost and a few other possibilities but no luck.

I also checked that $c->{send_email} = \&EPrints::Email::send_mail_via_smtp; was uncommented in

FWIW: After trying these things I did restart apache although I am not sure if it matters.

IS anyone using ssmtp with Eprints and has an idea what to look for? If not maybe I will need to try Exim4 or Postfix.

Thanks,
Edward


*** Options: http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech

*** Archive: http://www.eprints.org/tech.php/

*** EPrints community wiki: http://wiki.eprints.org/

*** EPrints developers Forum: http://forum.eprints.org/


*** Options: http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech
*** Archive: http://www.eprints.org/tech.php/
*** EPrints community wiki: http://wiki.eprints.org/
*** EPrints developers Forum: http://forum.eprints.org/

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.ecs.soton.ac.uk/pipermail/eprints-tech/attachments/20160602/9450c640/attachment-0001.html