[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[EP-tech] Re: system unable to send email (once more !)



Hello there,


Thanks a lot, Adam and John for your answers !

Now I don't see anymore the quoted previous error message about the ? system 
unable to send email ?...

But I haD to investigate a little further more, as the recipients of the emails 
don't receive them !!! In "/var/log/httpd/error_log" file, I see this error 
message : ? sendmail: fatal: chdir /var/spool/postfix: Permission denied ?...
So the fix is to issue the following command :
"setsebool httpd_can_sendmail on"


Best regards
--
Laurent Cloarec
Service Commun de la Documentation - Service Num?rique Documentaire
Biblioth?que Universitaire de l'Arsenal (bureau BU 017)
Universit? Toulouse 1 Capitole
11 rue des Puits-Creus?s
31042  TOULOUSE  Cedex 9 (France)
t?l. : (+33)(0)5.34.45.61.23




> ------------------------------
> Message: 3
> Date: Tue, 17 Feb 2015 11:23:05 +0000
> From: "Field A.N." <af05v at ecs.soton.ac.uk>
> Subject: [EP-tech] Re: system unable to send email (once more !)
> To: eprints-tech at ecs.soton.ac.uk
>
> Hi Laurent
>
> 	Have a look in your repository's email.pl configuration file (located in <eprints_root>/archives/<archive_id>/cfg/cfg.d/).  You should be able to control which function is used for sending email by uncommenting and commenting various options.
>
> 	Best Wishes
>
> --
> Adam Field
> Business Relationship Manager and Community Lead
> EPrints Services

> ------------------------------
> Message: 5
> Date: Tue, 17 Feb 2015 11:40:11 +0000
> From: John Salter <J.Salter at leeds.ac.uk>
> Subject: [EP-tech] Re: system unable to send email (once more !)
> To: "'eprints-tech at ecs.soton.ac.uk'" <eprints-tech at ecs.soton.ac.uk>
>
> See also the files in:
> ~/lib/syscfg.d/
>
> (and read the README before [NOT] editing anything!)
>
> Cheers,
> John