[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[EP-tech] Re: Create Account error



Open inscription exact. It's not from the Bazaar. I conducted tests on 
my old system (3.2), and all works normally with the same url. I have 
not made a particular change after the update. I saw that the files" 
Confirms "and" register "(in" / cgi ") have changed between the two 
versions (3.2 and 3.3 ).

I do not know how to debug this dysfunction.

Thanks for your help John.

Jean-Marie

Le 14/10/2014 10:55, John Salter a ?crit :
>
> Hmm,
>
> Which register route is this user using ? LDAP or ?open inscription? 
> (is this from the Bazaar?) .
>
> I?m guessing the second ? is there a ?Register::???? screen with that 
> route?
>
> If so, it looks like the confirm link should have a 
> ?screenid=Register::???? parameter to reach this?
>
> Cheers,
>
> John
>
> *From:*eprints-tech-bounces at ecs.soton.ac.uk 
> [mailto:eprints-tech-bounces at ecs.soton.ac.uk] *On Behalf Of 
> *Jean-Marie Le Bechec
> *Sent:* 14 October 2014 08:44
> *To:* eprints-tech at ecs.soton.ac.uk
> *Subject:* [EP-tech] Re: Create Account error
>
> Well, I do not know how to advance !
>
> in my logs, I see only this:
>
> /==> /var/log/httpd/ssl-oatao-access_log <==
> 194.167.203.49 - - [14/Oct/2014:09:46:50 +0200] "POST /cgi/register 
> HTTP/1.1" 200 7291
>
> ==> /var/log/httpd/eprints-oatao-access_log <==
> 194.167.203.49 - - [14/Oct/2014:09:47:34 +0200] "GET 
> /cgi/confirm?userid=2315&pin=8482A0D9BB31DD86 HTTP/1.1" 302 - "-" 
> "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like 
> Gecko) Ubuntu Chromium/37.0.2062.120 Chrome/37.0.2062.120 Safari/537.36"
>
> ==> /var/log/httpd/ssl-oatao-access_log <==
> 194.167.203.49 - - [14/Oct/2014:09:47:34 +0200] "GET 
> /cgi/confirm?userid=2315&pin=8482A0D9BB31DD86 HTTP/1.1" 302 386
> 194.167.203.49 - - [14/Oct/2014:09:47:34 +0200] "GET 
> /cgi/register?userid=2315&pin=8482A0D9BB31DD86&_action_confirm=1 
> HTTP/1.1" 200 12133
> 194.167.203.49 - - [14/Oct/2014:09:47:35 +0200] "GET 
> /images/logo_blanc.gif HTTP/1.1" 200 6770
> ......
>
> /when I try to confirm by clicking on the link, I get the following 
> message (see (attached  image)
>
> and in the database, i see this:
>
> /|   2315 |          1 | jmlb     | NULL     | user     | NULL     | 
> ?method=2&salt=g6&digest=38f0b413011e714ce8b764b99cf0d05f23fa9f3f6b7ff563755e5e39012b555983723efd983a084774400f9b269804f1ba297cd8b25f23b93ad45987e708a190 
> | 8482A0D9BB31DD86 | 1413272810 |        2014 |           10 |         
> 14 |           7 |            46 |            50 | 
> lebechec at inp-toulouse.fr <mailto:lebechec at inp-toulouse.fr> | NULL | 
> never     | FALSE     |     NULL |      NULL |                 | 
> jm         | lb          | | NULL | NULL | NULL    | NULL    | 
> TRUE      | NULL | NULL | NULL           | NULL       | NULL    |/
>
>
> The only solution is to assign a password to the user via the 
> administrator account. Do you have an idea that would allow me to move 
> forward?
>
> Thanks.
>
> Jean-Marie
>
>
>
>
>
> Le 13/10/2014 16:00, Jean-Marie Le Bechec a ?crit :
>
>     h?las no...
>
>     if i change the URL, i am back to the login screen. After, as an
>     administrator, if I modify the user account, the user can connect
>     without problem.
>
>     Jean-Marie
>
>     Le 13/10/2014 15:15, John Salter a ?crit :
>
>         I think that when a user is logged in, the ?Create Account?
>         screen is not accessible (as the user already has an account ?
>         as they are logged in!).
>
>         When the account is confirmed, and you are on the ?You may not
>         perform that action? screen, try changing the URL to
>         http://your.repo/cgi/users/home
>
>         - does this result in the same message?
>
>         Does the toolbar look like a user is logged in (e.g. there
>         isn?t a ?Create Account? or ?Register? link, but there is a
>         ?Logout? or ?Logged in as?? link).
>
>         It sound like the ?FirstTool? isn?t properly set ? I think
>         this should default to the Manage Deposits screen?
>
>         Cheers,
>
>         John
>
>         *From:*eprints-tech-bounces at ecs.soton.ac.uk
>         <mailto:eprints-tech-bounces at ecs.soton.ac.uk>
>         [mailto:eprints-tech-bounces at ecs.soton.ac.uk] *On Behalf Of
>         *Jean-Marie Le Bechec
>         *Sent:* 13 October 2014 13:05
>         *To:* eprints-tech at ecs.soton.ac.uk
>         <mailto:eprints-tech at ecs.soton.ac.uk>
>         *Subject:* [EP-tech] Create Account error
>
>         Hi all,
>
>         I just realized that the feature "Create Account" no longer
>         works since the update of my version of Eprints (3.2 --> 3.3).
>         I have two authentication type :  ldap and open inscription.
>
>         The user is receiving an email to confirm its registration (he
>         is also well created in the database) but if he valid by
>         clicking on the link, the user is redirected to the "Create
>         Account" screen with the following message "You May Not That
>         perform action." The user can not connect of course.
>
>         However, the "pin ID" link is the one contained in the database.
>
>         I see nothing in the logs except this: "Undefined phrase:
>         Plugin/Screen/Register:action:confirm:title (en) at line 348
>         in /appli/eprints/perl_lib/EPrints/Plugin.pm"
>
>         Thanks for your help.
>
>         Jean-Marie
>
>
>
>
>         -- 
>
>           
>
>         ***********************************************
>
>         Jean Marie Le Bechec
>
>         Service Commun de la Documentation
>
>         Responsable ingenierie documentaire
>
>         &
>
>         Direction du Systeme d'Information
>
>         Referent Etudes
>
>           
>
>         Institut National Polytechnique de Toulouse
>
>         6 allee Emile Monso - bp 34038 -
>
>         31029 Toulouse cedex 4
>
>         Tel : 05 34 32 31 16
>
>         Mail :lebechec at inp-toulouse.fr  <mailto:lebechec at inp-toulouse.fr>
>
>         ***********************************************
>
>
>
>
>         *** Options:http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech
>
>         *** Archive:http://www.eprints.org/tech.php/
>
>         *** EPrints community wiki:http://wiki.eprints.org/
>
>         *** EPrints developers Forum:http://forum.eprints.org/
>
>
>
>     -- 
>
>       
>
>     ***********************************************
>
>     Jean Marie Le Bechec
>
>     Service Commun de la Documentation
>
>     Responsable ingenierie documentaire
>
>     &
>
>     Direction du Systeme d'Information
>
>     Referent Etudes
>
>       
>
>     Institut National Polytechnique de Toulouse
>
>     6 allee Emile Monso - bp 34038 -
>
>     31029 Toulouse cedex 4
>
>     Tel : 05 34 32 31 16
>
>     Mail :lebechec at inp-toulouse.fr  <mailto:lebechec at inp-toulouse.fr>
>
>     ***********************************************
>
>
>
>
>     *** Options:http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech
>
>     *** Archive:http://www.eprints.org/tech.php/
>
>     *** EPrints community wiki:http://wiki.eprints.org/
>
>     *** EPrints developers Forum:http://forum.eprints.org/
>
>
>
> -- 
>   
> ***********************************************
> Jean Marie Le Bechec
> Service Commun de la Documentation
> Responsable ingenierie documentaire
> &
> Direction du Systeme d'Information
> Referent Etudes
>   
> Institut National Polytechnique de Toulouse
> 6 allee Emile Monso - bp 34038 -
> 31029 Toulouse cedex 4
> Tel : 05 34 32 31 16
> Mail :lebechec at inp-toulouse.fr  <mailto:lebechec at inp-toulouse.fr>
> ***********************************************
>
>
> *** Options: http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech
> *** Archive: http://www.eprints.org/tech.php/
> *** EPrints community wiki: http://wiki.eprints.org/
> *** EPrints developers Forum: http://forum.eprints.org/

-- 

***********************************************
Jean Marie Le Bechec
Service Commun de la Documentation
Responsable ingenierie documentaire
&
Direction du Systeme d'Information
Referent Etudes

Institut National Polytechnique de Toulouse
6 allee Emile Monso - bp 34038 -
31029 Toulouse cedex 4
Tel : 05 34 32 31 16
Mail : lebechec at inp-toulouse.fr
***********************************************

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.ecs.soton.ac.uk/pipermail/eprints-tech/attachments/20141014/14597114/attachment-0001.html