[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[EP-tech] Re: EPrints 3.3.12 Installation (from source)



Hi,

This mail just to keep you informed...

I started over from a clean snapshot of our system.
I reinstalled EPrints 3.3.12 from the source and a few required 
softwares from "yum" utility.
Then I ran epadmin and got one of the errors I had the first time :

    Can't load '/usr/local/lib64/perl5/auto/APR/APR.so' for module APR:
    libexpat.so.0: cannot open shared object file: No such file or
    directory at /usr/lib64/perl5/DynaLoader.pm line 200.
      at /usr/local/lib64/perl5/APR/Table.pm line 23
    [...]

As expat was installed (as said by "yum install expat"), the first time, 
I tried reinstalling Perl (and mod_perl). And things went worse... :-(
This time, I asked around me and somebody suggested the following command:

    yum install compat-expat1

I did it and it worked.
EPrints is now installed and working.

Thanks again for your help
Gilles



Le 05/03/2014 11:48, Gilles Fourni? a ?crit :
> Hi,
>
> We are fresh newcomers to the EPrints community (Cirad is a French 
> research centre working in the field of tropical agronomy, breeding, ...).
>
> The library team has made the choice of EPrints to manage the 
> documents produced by our research teams.
>
> So, I am trying to install EPrints 3.3.12 on the dedicated server (the 
> server is still in intranet zone, for now, so I can't post useful links) :
>
>   * CentOS release 6.5 (Final)
>     LSB_VERSION=base-4.0-amd64:base-4.0-noarch:core-4.0-amd64:core-4.0-noarc
>
>   * MySql 5.6.15
>   * Perl 5.18.2
>   * Apache 2.2.26 with mod_perl 2.0.8
>
> Installation of EPrints seems OK :
>
>   * "epadmin create", to create the test repository + modification of
>     httpd.conf
>   * import of testdata
>   * generate_views
>   * "indexer start"
>
> But, I still get errors when running unit_tests...
>
>   * one error on 30_search.pl
>   * fails (exists) on 84_sword.pl "1/27 Bailout called.  Further
>     testing stopped:  Failed to parse
>     http://-----.cirad.fr/sword-app/servicedocument :1: parser error :
>     Space required after the Public Identifier"
>
> And on the web interface I run through several problems :
>
>  1. When I try to login with the admin account created during "epadmin
>     create", I get a page "Moved" instead of the "Manage deposits"
>     page. I have found that another user reported the same problem
>     (http://www.eprints.org/tech.php/18174.html) but I didn't find any
>     answer to his mail.
>
>     If I go back one page, I return to the home page and I can see
>     that the connection has been done. I am identified under the admin
>     account...
>
>  2. If I try to edit the user profile through the "Profile" link, I
>     get an error : "user does not exist. It may have been erased."
>
>     The url of this page is
>     http://-----.cirad.fr/cgi/users/home?screen=Workflow%3A%3AView&dataset=user&dataobj=
>
>     If I tweak this URL, adding "1" at the end, I obtain the profile
>     page...
>
>  3. On this profile page, if I click on "Edit", this produce a "500
>     Internal Server Error"
>
>     The Apache log has a line related to this error : "Can't call
>     method "action_buttons" on an undefined value at
>     /opt/www/eprints-3.3.12/perl_lib/EPrints/Plugin/Screen/Workflow/Edit.pm
>     line 206."
>
>     Note: if I don't click "Edit" but rather one of the links on field
>     titles (as Name or User Type), I get to the edit page
>     (http://-----.cirad.fr/cgi/users/home?screen=Workflow%3A%3AEdit&dataset=user&dataobj=1&userid=1&stage=default#name)
>     without a problem.
>
>  4. I get the same kind of problems when trying to edit documents.
>     From the "Manage deposits" page, I can view documents but not edit
>     them : same "500 Internet Server Error" but with a different line
>     in the error_log " Can't call method "render" on an undefined
>     value at /opt/www/eprints-3.3.12/perl_lib/EPrints/Workflow.pm line
>     446.". As for the user editing, if I click on a title link from
>     the view page of a document, I correctly reach the edit page.
>
>  5. Last problem. When I try to search the repository
>     (http://-----.cirad.fr/cgi/search//simple or advanced), I get a
>     redirection error from firefox : "The page isn't redirecting
>     properly - Firefox has detected that the server is redirecting the
>     request for this address in a way that will never complete"
>
> Has anybody any clue or advices of things I should look at...
>
> With all my apologies for this long message...
> Thank you for your assistance.
>
> Gilles
>
>   * Anglais - d?tect?
>   * Anglais
>   * Fran?ais
>   * Espagnol
>
>   * Anglais
>   * Fran?ais
>   * Espagnol
>
>
>
> *** Options: http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech
> *** Archive: http://www.eprints.org/tech.php/
> *** EPrints community wiki: http://wiki.eprints.org/
> *** EPrints developers Forum: http://forum.eprints.org/

<javascript:void(0);>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.ecs.soton.ac.uk/pipermail/eprints-tech/attachments/20140310/daec7378/attachment-0001.html