[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[EP-tech] FW: Issues uploading files



Is there any potential that this could be a server/firewall issue?

From: eprints-tech-bounces at ecs.soton.ac.uk [mailto:eprints-tech-bounces at ecs.soton.ac.uk] On Behalf Of Andrew Beeken
Sent: 14 July 2017 13:23
To: eprints-tech at ecs.soton.ac.uk
Subject: Re: [EP-tech] FW: Issues uploading files

Hmm, I thought it might have been a permissions issue. I checked the folders and saw that the new ones being created under disk0 were being set to user www-data. I checked in the envvars and apache was running as www-data. Changed it to eprints, restarted apache but still nothing. It?s not even creating new folders under disk0. Chowned all the existing folders to eprints:eprints, perms are drwxrwsr-x. Checked the error log and I?m not seeing anything in there. It?s odd, I?m not sure where to look next.

From: eprints-tech-bounces at ecs.soton.ac.uk<mailto:eprints-tech-bounces at ecs.soton.ac.uk> [mailto:eprints-tech-bounces at ecs.soton.ac.uk] On Behalf Of Adam Field
Sent: 12 July 2017 11:16
To: eprints-tech at ecs.soton.ac.uk<mailto:eprints-tech at ecs.soton.ac.uk>
Subject: Re: [EP-tech] FW: Issues uploading files

Things to investigate:

                ls -l <eprints_root>
                ls -l <eprints_root>/archives/<archive_id>/documents
                ls -l <eprints_root>/archives/<archive_id>/documents/<path for the eprint id you?re failing to upload to>

                Check user, group and permissions

                Next, check what user the apache process is running as.  This is in the apache configuration file.  Its location varies depending on what distribution it?s in.  Compare that user to the user in the permissions above.

                Next, use:

                                df -h

                ?to check that you have adequate disk space (it?s almost certainly not that -- you?d have other issues if it were).

                Actually, before you even to that, it?s probably a good bet to check the apache error log to see if you can get any clues there.  If apache is complaining at you, it?s probably an issue with the server.  Again, the location of the error log varies by server, but it?s a default anyway and may be overridden by the config.  Check your apache configuration to see where the error log is being stored.  It might be /var/log/apach/error.log -- you?ll probably need to be root to see it.  The ?tail -f <error_log_full_path>? command is your friend.  It?ll show you the most recent entries in the log, and then display them as they come in.  Run that command and then try to upload a file, see what the error it.  It?s likely to be lots of lines.  You sorta need to read all of them to see if you can find the critical line that gives you the clue -- it?s likely to be the first or second line, but it might be buried.  Note that a problem like this causes knock-on issues, so there may be lots of sifting to do.

--
Adam



From: <eprints-tech-bounces at ecs.soton.ac.uk<mailto:eprints-tech-bounces at ecs.soton.ac.uk>> on behalf of Andrew Beeken <anbeeken at lincoln.ac.uk<mailto:anbeeken at lincoln.ac.uk>>
Reply-To: <eprints-tech at ecs.soton.ac.uk<mailto:eprints-tech at ecs.soton.ac.uk>>
Date: Wednesday, 12 July 2017 10:45
To: "eprints-tech at ecs.soton.ac.uk<mailto:eprints-tech at ecs.soton.ac.uk>" <eprints-tech at ecs.soton.ac.uk<mailto:eprints-tech at ecs.soton.ac.uk>>
Subject: [EP-tech] FW: Issues uploading files

Any thoughts on this as well? I?ve tested it again and I?m not getting an error through file upload however if I try to add a file from URL I?m getting a ?document creation failed? error. I?m not sure if it?s a permissions issue or a server issue (firewall etc)

Andrew

From: Andrew Beeken
Sent: 23 June 2017 12:15
To: eprints-tech at ecs.soton.ac.uk<mailto:eprints-tech at ecs.soton.ac.uk>
Subject: Issues uploading files

Hello all,

Another problematic one ? I can?t seem to upload files to my new repository. On doing an upload it briefly brings up the progress bar which then promptly vanishes. For info, I?m trying to upload a ?test.pdf? file which is fairly small, only containing the word test, that I have in reserve for this kind of occasion. I?ve checked folder permissions and they?re all eprints:eprints, and as I?m not getting an error I?m not sure where the problem may lie. The only thing I can think of is that I notice the EPrint ID index has started at 1 after importing my EPrints (via a direct database import) so I?m not sure if there?s a way to start indexing after the most recent EPrint ID? The document problem seems to be some kind of permissions thing to me, though.

Andrew

The University of Lincoln, located in the heart of the city of Lincoln, has established an international reputation based on high student satisfaction, excellent graduate employment and world-class research.

The information in this e-mail and any attachments may be confidential. If you have received this email in error please notify the sender immediately and remove it from your system. Do not disclose the contents to another person or take copies.

Email is not secure and may contain viruses. The University of Lincoln makes every effort to ensure email is sent without viruses, but cannot guarantee this and recommends recipients take appropriate precautions.

The University may monitor email traffic data and content in accordance with its policies and English law. Further information can be found at: http://www.lincoln.ac.uk/legal.
*** Options: http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech *** Archive: http://www.eprints.org/tech.php/ *** EPrints community wiki: http://wiki.eprints.org/ *** EPrints developers Forum: http://forum.eprints.org/
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.ecs.soton.ac.uk/pipermail/eprints-tech/attachments/20170714/da5911e8/attachment-0001.html