[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[EP-tech] Re: https problem?



Thanks Jon and Dave

I'm actually just messenger here for our infrastructure folk who tell me they have been through this page's recommendations though their "normal standards are slightly different so it wasn't exactly the same but should have been equivalent."

They'll try stripping out all the https bits and redoing them; failing that, as we are just evaluating internally, they'll let me have a http version for now but if you have any further insight to the https problem please let me know.

Cheers

Nick


-----Original Message-----
From: eprints-tech-bounces at ecs.soton.ac.uk [mailto:eprints-tech-bounces at ecs.soton.ac.uk] On Behalf Of Jon Hallett
Sent: 19 April 2013 09:51
To: eprints-tech at ecs.soton.ac.uk
Subject: [EP-tech] Re: https problem?

As Dave says, make sure you've done everything in http://wiki.eprints.org/w/How_to_use_EPrints_with_HTTPS. We forgot about secure.xml, and that caused some pretty odd problems of this sort.

Thanks,

Jon


-----Original Message-----
Message: 2
Date: Thu, 18 Apr 2013 16:19:33 +0000
From: "Sheppard, Nick" <N.E.Sheppard at leedsmet.ac.uk>
Subject: [EP-tech]  	
To: "eprints-tech at ecs.soton.ac.uk" <eprints-tech at ecs.soton.ac.uk>
Message-ID:
	<51C7E62521213341A6DDF35310AA1D57222E6655 at EXC-MBX02.leedsmet.ac.uk>
Content-Type: text/plain; charset="us-ascii"

Dear eprints techs

We continue to have problems getting eprints (3.3.11) working on a dev server -we have set up to use https and it redirects from http://eprints-eval  to https://eprints-eval correctly but seems to specify non-https links in the menu (Manage deposits, Manage records, Profile etc) which bounces you back to the non-https site which redirect you again, but by this time has lost the session so you need to log in again (oddly, the 'edit page phrases' and 'logout' links do work OK and point at the https version...) Is it perhaps a config issue and if so any idea of the files we should be looking at?

Thanks

Nick


Nick Sheppard
Repository Developer
The Headingley Library
James Graham Building
Leeds Metropolitan University
Beckett Park
Leeds
LS6 3QS
Tel: 0113 812 4731
email: n.e.sheppard at leedsmet.ac.uk<mailto:n.e.sheppard at leedsmet.ac.uk>
blog: http://repositorynews.wordpress.com/
twitter: https://twitter.com/#!/mrnick

Technical Officer - UK Council of research Repositories (UKCoRR) - http://www.ukcorr.org/



To view the terms under which this email is distributed, please go to http://disclaimer.leedsmet.ac.uk/email.htm
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.ecs.soton.ac.uk/pipermail/eprints-tech/attachments/20130418/de1be06a/attachment-0001.html 

------------------------------

Message: 3
Date: Thu, 18 Apr 2013 17:52:31 +0100
From: Dave Anderson <dave at marlinbrighton.com>
Subject: [EP-tech] Re: https problem?
To: eprints-tech at ecs.soton.ac.uk
Message-ID: <517024CF.9070205 at marlinbrighton.com>
Content-Type: text/plain; charset="iso-8859-1"

What OS are you using? Have you done all of this?

http://wiki.eprints.org/w/How_to_use_EPrints_with_HTTPS



regards
Dave
--
http://www.marlinbrighton.com



On 18/04/2013 17:19, Sheppard, Nick wrote:
>
> Dear eprints techs
>
> We continue to have problems getting eprints (3.3.11) working on a dev 
> server --we have set up to use https and it redirects from 
> http://eprints-eval  to https://eprints-eval <https://eprints-eval> 
> correctly but seems to specify non-https links in the menu (Manage 
> deposits, Manage records, Profile etc) which bounces you back to the 
> non-https site which redirect you again, but by this time has lost the 
> session so you need to log in again (oddly, the 'edit page phrases'
> and 'logout' links do work OK and point at the https version...)
>
> Is it perhaps a config issue and if so any idea of the files we should 
> be looking at?
>
> Thanks
>
> Nick
>
> Nick Sheppard
>
> */Repository Developer/*
>
> The Headingley Library
>
> James Graham Building
>
> Leeds Metropolitan University
>
> Beckett Park
>
> Leeds
>
> LS6 3QS
>
> Tel: 0113 812 4731
>
> email: n.e.sheppard at leedsmet.ac.uk 
> <mailto:n.e.sheppard at leedsmet.ac.uk>
>
> blog: http://repositorynews.wordpress.com/
>
> twitter: https://twitter.com/#!/mrnick 
> <https://twitter.com/#%21/mrnick>
>
> Technical Officer - UK Council of research Repositories (UKCoRR) - 
> http://www.ukcorr.org/
>
>
>
> To view the terms under which this email is distributed, please go to 
> http://disclaimer.leedsmet.ac.uk/email.htm
>
>
>
>
> *** Options: 
> http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech
> *** Archive: http://www.eprints.org/tech.php/
> *** EPrints community wiki: http://wiki.eprints.org/

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.ecs.soton.ac.uk/pipermail/eprints-tech/attachments/20130418/d90707d5/attachment.html 

------------------------------

_______________________________________________
Eprints-tech mailing list
Eprints-tech at ecs.soton.ac.uk
http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech


End of Eprints-tech Digest, Vol 55, Issue 21
********************************************



*** Options: http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech
*** Archive: http://www.eprints.org/tech.php/
*** EPrints community wiki: http://wiki.eprints.org/


To view the terms under which this email is distributed, please go to http://disclaimer.leedsmet.ac.uk/email.htm